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Objective: The goal of this tutorial is to describe in sufficient detail the steps necessary to                             
analyze the environmental and health effects of pollution diffusion from ETS (treatment group)                       
industries (“firms” in the nonIndian context) versus control group industries, using some specific                       
modeling assumptions on the pollution diffusion side and pulling previous results on the linear                         
relationship between PM abatement and infant mortality. With this short manual, and its                       
associated video tutorial you should be able to recreate the results generated here. Doing so                           
should also give you enough familiarity with GIS to venture into other types of GIS analysis, so                               
hopefully this can serve as a general GIS reference guide as well.

Basic Background: The dominant stateoftheart GIS software is called ArcMap (ArcGIS) and                     
is produced by the ESRI company, but it is prohibitively expensive (usually in the $1000s) and is                               
heavy for laptop processors. While opensource software is advancing (as is computing power),                       
these software remain quite buggy but with a little patience and resourcefulness (searching                       
troubleshoot forums etc.), they do the job just fine. Based on my experience, two opensource                           
softwares warrant attention, and these will be the two we will work with (in addition to Google                               
Earth which can be used for generating raw data): qGIS and MapWindow. Each has its                           
advantages and disadvantages, but qGIS tends to have a broader range of builtin analysis tools,                           
while MapWindow mimics ArcMap in its output layout  the actual presentation of the map                              
which is important when presenting the final PDF or PPT versions of the maps.

Step 1: Download the Programs

a. qGIS:http://hub.qgis.org/projects/quantumgis/wiki/Download
b. MapWindow: http://mapwindow4.codeplex.com/releases (Be sure to download v4.8)
c. Google Earth: http://www.google.com/earth/download/ge/agree.html
d. kml2shp plugin: http://www.mapwindow.org/downloads/ (Note: if this plugin page does                 
not work you may need to download MapWindow v4.7 on the right hand side of the                             
downloads page from part (b.), and use the following v4.7compatible kml2shp plugin:                     
http://shape2earthengine.com/apps/kml2shapefile1.0.0.1_setup.zip)

The plugin listed in (d.) is important as it allows one to convert .kml or .kmz files, such as pins                                     
or points (placemarks) on a google map or anything created in Google Earth to .shp files (“shape                               
files”), which can then be imported to GIS as “layers” of geographic data. Installing opensource                           
plugins can be difficult as they are sometimes only compatible with certain program versions,                         
however you can check in MapWindow>Menu>Plugins whether your plugin was properly                   
installed and turned on. Normally a plugin should be placed in your plugins folder within                           
MapWindow, however if you have problems I would suggest doing a google search as others                           
have likely had the same problem and documented it in a public forum.
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Step 2: Familiarize Yourself with the Main Objects of Mapping Software

The Basic Steps: A GIS map is constructed by importing “layers” of data (.shp files) one                             
by one into a legend, and then operating on those layers (analyzing, merging with other                           
layers, transforming the data, etc.), and exporting the newly operated layers as their own                         
new .shp files. We then choose our preferred way to display the data by “symbologizing”                           
the new (and/or old) layers with appropriate data ranges, colors schemes, and other                       
considerations. Finally, before we export the map, we overlay the legend representing the                       
chosen “symbology” (ranges) on top of the displayed data and export our final map. For                           
the remainder of the tutorial, you should have access to the following raw data on Indian                             
census layers  found in the directory GIS>Raw Data>Indian Census Layers:

1. 95feindiamap_district.shp
2. 95feindiamap_state.ship
3. 95feindiamap_sub_dist.shp
4. 95feindiamap_town_dist.shp

Layers (.shp files): Each .shp file can be imported as a layer (in MapWindow using                           
+Add; in qGIS using Menu>Layer>Add Vector Layer or Control+Shift+v ), and can be                       
displayed similar to how one would do so in Photoshop  layers can be turned off, turned                               
on, and rearranged from top to bottom representing the priority of display (front to back).                           
Each time a layer is added, turned on or off, or edited, the display on the right should                                 
adjust accordingly. What makes GIS layers unique is that each layer contains a database                         
(matrix) associated with geographical characteristics “features”. These features are               
typically classified as point layers (for points like the town data) or polygon layers (for                           
regions and shapes like districts). To begin, play around with these 4 .shp  files.

Useful Tools: When playing around with layers, a few tools come in handy. There is                           
usually some kind of information arrow tool that allows you to select a specific                         
geographic feature and obtain information on it (for example on a single town or district).                           
There will also however, be a separate selection arrow (or tool) that allows you to create                             
a “selection” (either by clicking different pieces of data cummulatively holding shift or                       
using some kind of broader selection swath). One can thus manually create a selection                         
and then export it as a new layer, carrying over the same underlying data (explained                           
later). Note: If you are ever lost from your main data (the feeling that you are in white                                 
purgatory space far from your geography or data), there is usually an “extent” button (in                           
MapWindow / ArcMap) which adjusts the display to span the entire geography of the                         
turned on layers  zooming just wide enough to circumscribe all of India in this case.

The Attribute Table: What makes GIS data different from regular data is that each GIS                           
layer has an underlying attribute table, or database matrix associated with its geography.                       
Sure enough, when you create a new .shp file (or import one), many other files with                             
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different suffixes are saved, including a standard .dbf database file along with a .shx and                           
.prj file. We will ignore the latter two for now. Either way, attribute tables should serve as                               
your points of departure when it comes to analysis, symbology (displaying different                     
variables of your database according to some criteria), operations and data mergers. Get                       
comfortable with opening the attribute table under each layer and observing the data.

In MapWindow, right clicking any layer should present the “attribute table editor”, from                       
which we can create operations and export freshly operated layers as new layers. This                         
can be done manually using the selection tool as explained in the paragraph above, but                           
more generally, we use “queries” to select specific data or geographic features that meet                         
a certain mathematical or spatial expression criteria (the query builder is SQL based, for                         
those of you familiar with MS Access). I will explain how this is done in detail in the                                 
analysis sections below, however the basic idea is that one can grab data that fits a                             
certain range (i.e. >50), or that meets a certain string expression (i.e. == “Gujarat”), and                           
there even exist “spatial queries” which can for example, select all districts within a                         
specified kilometer radius from Delhi.

In qGIS, after adding a layer to the mainframe, you can rightclick any layer and select                             
“Open Attribute Table” or select it with Menu>Layer>Open Attribute Table. It bears noting                       
that we often need multiple copies of the same layer if we want to display an intricate                               
map. For example, you might want two copies of the district layer, one for ETSaffected                           
districts and one for the remaining districts that have zero effect, so that you are not                             
always operating on irrelevant data and displaying extra noise when it is not relevant.                         
Most layers can be easily copy/pasted back into the legend to create multiple copies, or                           
you can just import the layer twice if this does not work. More on this later.

Important: It is always good practice to keep all your layers in the same folder or in highly                                 
organized folders. If you move them around the relative directory will be broken, and you                           
will have to reset the directory for each layer which can be painful. In case you are                               
worried that the operation you just performed was not succesful, one can explicitly export                         
any layer after it is created by using File>Export or Layer>Export, or right clicking a layer                             
in either program and export the layer from the Attribute Table under the “Selection” tab.                           
We will deal with this explicitly later on when we get into the example.

.KML and .KMZ files, and using Google Earth: One thing to keep in mind is that GIS                               
reads .shp files exclusively. If you have a common .kml file  for example  you (or an                                 
RA) has manually searched each firm name and placed a pin at each GPS coordinate,                           
and saved them under Google Earth Places in a joint folder  you cannot simply save                             
and import the single .kml file for this group of firms from Goolge Earth into your GIS but                                 
have to directly convert the .kml file into a .shp file. Fortunately, the addin kml2shp                           
should be great for this in MapWindow. For the meantime, all you really need to know                             
about using Google Earth is the following: if you create a “Place” under “Places”, and                           
rightclick that “Place” to add pins or placemarks, then when you are finished and “Save                           
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As”, you can save the Place as a .kml file which will save all of the pins within that place.

In this tutorial, you will not need to edit the .kml file but simply will need to convert it. Be                                     
sure to locate the following .kml file under GIS>Raw Data>ETS Industries> (Note: as the                         
sample is likely to have changed significantly since I last attained the data you will likely                             
have to make several manual adjustments in Google Earth):

1. Industries_GU_final.kml

Now, convert this into a .shp file and save the .shp file in the same directory. To see how                                   
this is done, refer to the example at the end of this tutorial or the video guide.

Queries and the Field Calculator: Using MapWindow for now, if you open an attribute                         
table you will notice some important buttons (tools) on the bottom of the window  “Build                             
Query” and “Field Calculator”. These allow you to do the types of things you would do in                               
Stata and R (generating and editing variables) without importing and exporting or worrying                       
about geography. For example, open the attribute table of any layer of your choosing, and                           
at the top menu select Edit > New Field. Then, by hitting the “field calculator” button at the                                 
bottom of the attribute table window, you could let your New Field (whatever you named                           
it) = Tot_Pop*2, which would give you a new variable that is double the size of Tot_Pop                               
for each object (district, town, etc.). This is a query, and the language used to build these                               
queries is SQL based, so if your code does not work out this is the reference language                               
(however the basic interface means you should rarely encounter coding errors here).

Finally you have to hit “apply” and then you can close the newly overwritten attribute table                             
and reopen it to check that the new field (variable) is there. Note you can always remove                               
this new field later (Edit>Remove Field), however, to avoid overwriting problems, it may                       
be prudent to export your layer under a new name to circumvent overwriting problems                         
(which we will do in a minute). Now we would like to create a new .shp layer based on                                   
just a selection of your data (for example, say you want to keep only those districts below                               
a certain threshold population like 500,000 and create a map of just those districts). We                           
use the “Query” tool/button at the bottom of the Attribute Table. Once the desired criteria                           
are selected, hit “execute” and then “new selection”. Then to export your new selection,                         
go to the top of the Attribute Table and hit Selection>Export Selected Features to create a                             
.shp file for just those “features” of the data you have queried. Now you have a new layer!

Toolboxes and Analysis Tools: Finally we come to the meat of GIS  analysis tools. In                             
addition to queries and new fields, both MapWindow and qGIS have built in tools that can                             
perform a number of useful preset procedures. In MapWindow, locate the Legend, and                       
switch tabs from Layers to Toolbox. In qGIS, locate Menu>Vector>Analysis Tools (and                     
note that there are also geoprocessing and other tools available). I will focus on a few                             
tools relevant to this analysis and that are useful in general, however there are many                           
analysis tools available, including usermade plugins, and one also has the option to                       
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write your own tools if ambitious. It is important to aware that not all the tools may be                                 
active unless the corresponding layers are already loaded. For example, tools that apply                       
to polygon layers will not be available unless a polygon .shp file is already imported.

MapWindow Important Analysis Tools:
1. Database Tools>Export Shape File
2. Projections>Reproject Shape FIle
3. Vector Operations>Standard>Merge Shape File
4. Vector Operations>Standard>Spatial Query
5. Vector Operations>Standard>Create Centroids (Also available in qGIS)

qGIS Important Analysis Tools:
6. Vector>Analysis Tools>Distance Matrix
7. Vector>Data Management Tools>Join Attributes by Location (Spatial Join)

These do the following:
1. Exports any .shp file into a new name
2. Reprojects layers onto a new satellite coordinate system (and base unit)
3. Merges two shape files together according to some criteria
4. Creates a query but with spatial criteria (i.e. within 30km of each point, …)
5. Uses a predesigned algorithm to determine the centroid point of all polygons in                         
a polygon layer, exports as a .shp file
6. Creates an nXn matrix of distances between two features (layers) (.csv)
(Can also be exported as a 3column OriginDestinationDistance matrix)
7. Merges the data of a polygon with its overlying point

We primarily use these tools to merge newly generated data directly into current .shp                         
files or as exported .csv files, which we will then need to merge back into the layers.

Project Map Files, Symbology, and Map Exporting: Once all analysis has been done                       
to create the final set of layers to be displayed on the map, import them into MapWindow.                               
Now it is time to represent our spatial data by “symbologizing” the layers, where each                           
layer corresponds to a variable of interest. To see this more concretely, start with the 4                             
census layers and work on one of the polygon layers. Doubleclick on it or rightclick the                             
layer and hit properties, then move to “categories” and “labels.” In categories you can set                           
ranges and choose a gradient color for a given variable, say tot_pop in the subdistrict                           
layer, where hitting “generate” will split the the category cutoffs according to the desired                         
number of quantiles. The “labels” tab further allows you to manually select the style and                           
positioning of the label, or turn labels on and off for every given layer, which is useful for                                 
the final display. Getting good at symbology comes with practice and will help beautify                         
your maps. For now, it is important to note that the “generate” button will erase whatever                             
symbology you had previously chosen without saving the previous symbology. So to                     
SAVE your symbology, you must save the entire project file. In MapWindow, this creates                         
a .mwprf file that saves all of the symbology relations (gradients, cutoff numbers for your                           
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bins, colors, etc.) for all layers, however this file does nothing with respect to saving your                             
actual data (.shp files / layers)  it is merely a way to link all of your .shp files together.

Note on Projections: All GIS layers are projected onto specific coordinate systems                     
(CRS), and there are many such CRSs. Sometimes two of your layers may be tailored to                             
two different satellite projections and they need to be converted to conform to each other.                           
Other times the CRS is not in the desired base unit and so any subsequent calculations                             
that have to do with distance may not be in a unit like meters but rather in decimal                                 
degrees or other hardtoconvert units. In these cases, you must reproject your .shp files                         
to different coordinate systems, which can be extremely painful and can suck up a large                           
amount of your time on GIS. I show an example below, however note that online forums                             
are your best friend when it comes to projections. Once you have figured out how to                             
properly reproject a .shp file on to a new CRS, the learning curve lightens significantly.

Step 3: General Steps of the ETS Project

Now, to put everything into practice, we will try to recreate a pollution diffusion map for the state                                 
of Gujarat like the one that is attached after the steps below (Map 1). Here is the stepbystep                                 
guide to do so (note that I perform these steps in the video tutorial, linked in the first paragraph):

(1) Locate the GIS Tutorial Materials folder. Check that it contains the following:
 4 Census .shp Layers (State, District, SubDistrict, Town)
 1 .kml files (GU Industries)
 1 “ SubDistricts Split” .shp file (this file cuts the subdistricts into smaller blocks so that                               
the pollution diffusion is finer. I did this manually in ArcGIS for each states, as I could not                                 
find the way to do this in open source software but I’m sure there is a way!)
 DiffusionFramework.R (R code for pollution diffusion model for data mergers)

(2) Add Layers. Open a new MapWindow map and load the 6 .shp files into the legend using                                 
Add+. Play around with the basic tools discussed above, and be sure that you’ve installed the                             
MapWindow kml2shp plugin (even if in v4.7). Note: there is no need to save any files in this step.

(3) Convert the .kml files into .shp files. Go to Menu>Plugins and select kml2shp (make sure that                               
it is turned on or in the correct plugins folder for MapWindow if you do not already see it). If it is                                         
correctly installed, you should see “kml” in the menu bar. Once this is the case, go to                               
Menu>kml>Import as Shape File, and then select the Gujarat .kml file containing all industries in                           
Gujarat, and convert it into a .shp file name of your choosing. I will be calling it by the same name                                       
but with the suffix .shp, Industries_GU_Final.shp (which is the default). Note that here you have                           
many options. Let me explain briefly what they do: “Convert to Shape File” is what you want. This                                 
creates a single .shp file. “Convert contents of folder to Shape File” will take the containing folder                               
and make several layers out of each of its .kml files. One interesting feature is that you can                                 
check the “Save Placemark Name is Attribute” box, which will put the industry name right in the                               
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attribute table! Check this box, and then be sure that the .shp file is added to your map, and you                                     
will have successfully converted a .kml into a .shp file!

(4) Query for Gujarat. So now we have a bunch of layers, and industries for the state of Gujarat.                                   
But to quicken our calculations and simplify our presentation, we should get rid of irrelevant parts                             
of the census layers. In other words, we want to keep only those layers that comprise the state                                 
of Gujarat at the finest geographic level, which in this case would be the “split subdistrict” level.

First, uncheck the box next to all layers except for your “split subdistrict” layer. Next, rightclick                             
the selected layer and selected Attribute Table Editor. Proceed to hit the halfhour glass button                           
called “Build Query” beneath the table. Next, doubleclick the variable STATE_UT or type the                         
variable name identically in the box below with [square brackets] around it. Then you want a                             
space followed by an equals sign and another space, “ = “, which you can either type in or select                                     
with buttons. Then choose the expression that you want to query for, so in this case “Gujarat”                               
with quotations around it. So the whole query should look like this: [STATE_UT] = "Gujarat".                           
Then hit “execute”. Once executed, a box should popup telling you the number of shapes                           
created. In this case, 488 split subdistricts should be created. Then select “1New Selection”                         
which tells GIS to create a new storage rather than adding to an existing one. Think of this like a                                     
clipboard in copy/paste world. Then X out of the querybuilder box until you are back to the                               
Attribute Table. You will notice that the selection you just queried for should be highlighted on                             
your map. (If your map isn’t properly scaled, hit the “extent” button at the top to zoom                               
appropriately.) Now, back in the Attribute Table Editor, go to Menu>Selection>Export Selected                     
Features and save your file in the tutorial folder as Split_Subdistricts_GU. Tell GIS to add the                             
new .shp file to your map, and presto, you have successfully queried for Gujarat.

(5) Create centroids layer for split subdistricts. In order to get the distances we need between                             
emissions sources (industries) and groundlevel PM concentration, we first need a point                     
measure of each split subdistrict block. First, let’s make sure that our .shp file has the                             
appropriate unique ID field. In MapWindow, rightclick the layer Splits_Subdistricts_GU and then                     
select Menu>Tools>Generate or Update MWShapeID Field. Then go back to the legend and                       
move from the tab “layers” to the tab “toolbox.” Then, under “Vector Operations” and “Standard”                           
select “Create Centroids”. Select the appropriate input .shp file and select “centroids” not                       
“centers.” You also need to manually select all the attribute table variables you want associated                           
with the centroids. Finally, change the suffix of the file to be Centroids.shp for simplicity, and                             
leave the “add to map” box checked, and presto, you have centroids!

(6) Create Distance Matrix. Now we will use qGIS’s predetermined distance matrix tool to                         
calculate the distance between all centroids and emission sources. This will export a .csv                         
distance file to be used as an input in our diffusion model which will eventually allow us to attain a                                     
PM concentration figure for each split subdistrict (or associated centroid.)

(6a) First, we encounter a projection issue that needs to be dealt with in MapWindow. The two                               
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associated .shp files (Centroids.shp and Industries_GU_Final.shp) are projected to a coordinate                   
system called WGS84 whose base unit is in decimal degrees (due to the elliptical nature of the                               
globe), while we want to reproject these layers to WGS84PseudoMercator whose base unit is                         
in linear meters. (All I can tell you about such projections and their nomenclature is that it usually                                 
refers to a geographic area  here the whole world  followed by its year.) To do this, load both                                     
layers into MapWindow and select the Toolbox tab in the Legend, Projections>Reproject Shape                       
File. Add both layers with the “+” symbol, on the right, and then on the left under Projected select                                   
WGS84PseudoMercator at the bottom of the menu. Note that when you execute this tool with                           
the “Reproject” button, the new projected layers may not add immediately, which is fine as long                             
as they are exported back to your tutorial folder. Check that the new layers have saved  they                                 
should have a suffix “_projected” (or something similar) added automatically to the original title.

(6b) Now that we have our projected layers, open qGIS and import the newly projected layers.                             
Now select Menu>Vector>Analysis Tools>Distance Matrix. Be sure to set the Input Layer as the                         
projected centroid layer, and the Target Layer as the industry layer. Set the unique ID fields                             
appropriately  in this case they should each be set to MWShapeID. Then select the “Standard”                             
button (Linear would create a 3column .csv file with the input, target, and distance), and lastly                             
create an export name for your .csv file and hit OK to process. (Note: you can see the difference                                   
between this and conducting the same distance matrix operation on the nonprojected layers,                       
which will produce a matrix of decimal degree units rather than meters.)

(7) Run R code DiffusionFramework.r*. This code calculates ground level PM concentration for                       
each split subdistrict using a Gaussian Plume (SCREEN) Model based on                   
http://san.hufs.ac.kr/~gwlee/session9/gaussian.html, and exports a .dbf file containing the total               
amount of groundlevel PM concentration (mg/m^3) in each subdistrict owing to ETS industries.                       
The model is as follows (thanks to Yuanjian Li for developing this):

exp[− ( ) ]x = Q
πσ σ uy z 2

1
σz
H 2

Where:
x = ground level concentration (g/m^3)
Q = source strength (g/s)
,   = plume standard deviations (m)σy σz

H = effective height of emission
u = wind speed at height H (m/s)
y = distance between source and industry (m)

Assumptions:
1. Constant wind speed in direction of wind: u = 37 km/h = 10 m/s**
2. Neutral Horizontal and Vertical Dispersion:

 (Horizontal),  = .008 σy = y * α * 1
√1+.0001 y*

α

 (Vertical),  = .006 σz = y * β * 1
√1+.00015 y*

β
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3. Random Stack Heights between 5  30 meters, 10 stacks/industry.
4. Source strength of 15 g/s per stack.
5. 10 stacks/industry.
6. ETS reduces groundlevel pollution to 60% of original level (simulation)

*R is a free (opensource) statistical analysis software that can be downloaded here:                       
http://cran.rproject.org/bin/windows/base/; R Studio has a better user interface but requires that                   
R be installed first: http://www.rstudio.com/ide/download/

**Lakshmanan, N. et al. Basic wind speed map of India with longterm hourly wind data. Current                             
Science, Vol. 96, No. 7, 10 April 2009, Bombay~37, Chennai~38, Ahmedabad~35.)

(8) Create Map (Symbologize Layers). First, load the Split_Subdistricts_GU.shp file back into                     
Mapwindow and open its attribute table to verify that the new PM concentration numbers are                           
there. Note that when you run the R code over and over, it may not rewrite, so you may need to                                       
discard or rename old versions of the PM concentration variables if they have been overwritten.                           
Now rightclick the layer, and select “Shapefile Categories” and then the “+” button on the left.                             
Then select “PM_before” under “Classification Field”, 10 categories, and for now use “Natural                       
Breaks” under “Classification Type.” Note that there are many classification types  one useful                         
one is quantiles. Now under “Visualization” choose one of the gradient color schemes. Note, if                           
you’re like me and were not satisfied with the existing color schemes, you can hit the “...” button                                 
to the right of the color schemes and hit “add” to create your own. Then hit “OK”. Lastly, hit                                   
“apply” and then “OK” and your map should populate nicely. Note, you can change the lowest                             
category to be a “neutral” color to emphasize which subdistricts are actually affected by                         
pollution since so many on the periphery of the state are not.

To verify that this is consistent with your industry locations, add the Gujarat industries layer and                             
move it to the top of the legend. In the tutorial I show options on how one can change the symbol                                       
marker, add the main city names, and edit labels. Finally, to produce your map go to the menu                                 
bar and select Project>Export and export each item in the Export menu. You can piece these                             
together on a powerpoint slide and then export it to .pdf to have your final map! I show more on                                     
the video tutorial on the options you have here. Note that you can add as many layers here as                                   
are appropriate, and export the map that is visually displayed to your liking. So for example, you                               
may want to display some kind of ratio of pollution to population density, using the field calculator                               
tool to add a new field and calculate this value, then symbologize it. See the example maps                               
following this section for some ideas. Either way, the last thing you will want to do and remember                                 
once you have created all of your layers is you can save all of your symbologies simultaneously                               
by exporting a project map file. So finally, go to Menu>Project>Save As, and you then have the                               
final piece to your puzzle!

This tutorial scratches the surface of what can be done with GIS, but there is plenty of                               
information online so with this base you should be able to navigate any GIS tool or operation                               
required for your project!
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Some Map Examples (note: different from tutorial)
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